use strict;
my $str = 'https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx';
my $regex = qr/.*(https)*\/(.*)\.(.*\?|.*$)(.*$)/mp;
my $subst = '$2.$3 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";