#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(https)*\/(.*)\.(.*\?|.*$)(.*$)"
Local $sString = "https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx"
Local $sSubst = "$2.$3 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)