# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*(https)*\\/(.*)\.(.*\?|.*$)(.*$)/$2.$3 /mg;t' <<< "https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx"