using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(https)*\/(.*)\.(.*\?|.*$)(.*$)";
string substitution = @"$2.$3 ";
string input = @"https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}