$re = '/.*(https)*\/(.*)\.(.*\?|.*$)(.*$)/m';
$str = 'https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx';
$subst = "$2.$3 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;