package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(https)*\/(.*)\.(.*\?|.*$)(.*$)`)
var str = `https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx`
var substitution = "$2.$3 "
fmt.Println(re.ReplaceAllString(str, substitution))
}