// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*(https)*\/(.*)\.(.*\?|.*$)(.*$)").unwrap();
let string = "https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx";
let substitution = "$2.$3 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}