const regex = /.*(https)*\/(.*)\.(.*\?|.*$)(.*$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(https)*\\\/(.*)\\.(.*\\?|.*$)(.*$)', 'mg')
const str = `https://dso.nr.ncia/qa/ivva/_layouts/15/listform.aspx`;
const subst = `$2.$3 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);