import Foundation
let pattern = #"(font-family):\s*([^;]*)[;'][;"]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span style="color: red;font-family:'Sanc';">test</span>
<span style="font-family:'Sanc';color: red;">test</span>
<span style="font-family:'Sanc'">test</span>
<span style="color: red;font-family:'Sanc';line-height: 15px;">test</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)