using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(font-family):\s*([^;]*)[;'][;""]";
string substitution = @"""";
string input = @"<span style=""color: red;font-family:'Sanc';"">test</span>
<span style=""font-family:'Sanc';color: red;"">test</span>
<span style=""font-family:'Sanc'"">test</span>
<span style=""color: red;font-family:'Sanc';line-height: 15px;"">test</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}