$re = '/(font-family):\s*([^;]*)[;\'][;"]/';
$str = '<span style="color: red;font-family:\'Sanc\';">test</span>
<span style="font-family:\'Sanc\';color: red;">test</span>
<span style="font-family:\'Sanc\'">test</span>
<span style="color: red;font-family:\'Sanc\';line-height: 15px;">test</span>';
$subst = "\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;