# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(font-family):\s*([^;]*)[;'][;"]/"/g;t' <<< "<span style=\"color: red;font-family:'Sanc';\">test</span>
<span style=\"font-family:'Sanc';color: red;\">test</span>
<span style=\"font-family:'Sanc'\">test</span>
<span style=\"color: red;font-family:'Sanc';line-height: 15px;\">test</span>"