import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(font-family):\\s*([^;]*)[;'][;\"]";
final String string = "<span style=\"color: red;font-family:'Sanc';\">test</span>\n"
+ "<span style=\"font-family:'Sanc';color: red;\">test</span>\n"
+ "<span style=\"font-family:'Sanc'\">test</span>\n"
+ "<span style=\"color: red;font-family:'Sanc';line-height: 15px;\">test</span>";
final String subst = "\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}