// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(font-family):\s*([^;]*)[;'][;"]"#).unwrap();
let string = "<span style=\"color: red;font-family:'Sanc';\">test</span>
<span style=\"font-family:'Sanc';color: red;\">test</span>
<span style=\"font-family:'Sanc'\">test</span>
<span style=\"color: red;font-family:'Sanc';line-height: 15px;\">test</span>";
let substitution = "\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}