const regex = /(font-family):\s*([^;]*)[;'][;"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(font-family):\\s*([^;]*)[;\'][;"]', 'g')
const str = `<span style="color: red;font-family:'Sanc';">test</span>
<span style="font-family:'Sanc';color: red;">test</span>
<span style="font-family:'Sanc'">test</span>
<span style="color: red;font-family:'Sanc';line-height: 15px;">test</span>`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);