import Foundation
let pattern = #"^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Jose Jose Romulo Ricardo, lopez de montana."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)