package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)`)
var str = `Jose Jose Romulo Ricardo, lopez de montana.`
var substitution = "\1\2\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}