use strict;
my $str = 'Jose Jose Romulo Ricardo, lopez de montana.';
my $regex = qr/^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)/p;
my $subst = '\\1\\2\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";