using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)";
string substitution = @"\1\2\3";
string input = @"Jose Jose Romulo Ricardo, lopez de montana.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}