#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)"
Local $sString = "Jose Jose Romulo Ricardo, lopez de montana."
Local $sSubst = "\1\2\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)