# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)/\1\2\3/g;t' <<< "Jose Jose Romulo Ricardo, lopez de montana."