re = /^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)/
str = 'Jose Jose Romulo Ricardo, lopez de montana.'
subst = '\\1\\2\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result