// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)").unwrap();
let string = "Jose Jose Romulo Ricardo, lopez de montana.";
let substitution = "\\1\\2\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}