$re = '/^(\p{L}+?\s)(\p{L}+?\s).*(,.*$)/';
$str = 'Jose Jose Romulo Ricardo, lopez de montana.';
$subst = "\1\2\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;