// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<script([^>]*)?>.*?<\/script>").unwrap();
let string = "<p>Hello</p><script type=\"text/javascript\">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src=\"javascript.js\"></script>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}