# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script([^>]*)?>.*?<\/script>"
test_str = "<p>Hello</p><script type=\"text/javascript\">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src=\"javascript.js\"></script>"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.