# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<script([^>]*)?>.*?<\\/script>//gm;t' <<< "<p>Hello</p><script type=\"text/javascript\">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src=\"javascript.js\"></script>"