const regex = /<script([^>]*)?>.*?<\/script>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script([^>]*)?>.*?<\\\/script>', 'gm')
const str = `<p>Hello</p><script type="text/javascript">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src="javascript.js"></script>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);