re = /<script([^>]*)?>.*?<\/script>/m
str = '<p>Hello</p><script type="text/javascript">const x = 29; console.log(\'Hello world\');</script><p>World</p><script>alert(\'Hello world\');</script><script src="javascript.js"></script>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result