package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<script([^>]*)?>.*?<\/script>`)
var str = `<p>Hello</p><script type="text/javascript">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src="javascript.js"></script>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}