use strict;
my $str = '<p>Hello</p><script type="text/javascript">const x = 29; console.log(\'Hello world\');</script><p>World</p><script>alert(\'Hello world\');</script><script src="javascript.js"></script>';
my $regex = qr/<script([^>]*)?>.*?<\/script>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";