$re = '/<script([^>]*)?>.*?<\/script>/m';
$str = '<p>Hello</p><script type="text/javascript">const x = 29; console.log(\'Hello world\');</script><p>World</p><script>alert(\'Hello world\');</script><script src="javascript.js"></script>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;