using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script([^>]*)?>.*?<\/script>";
string substitution = @"";
string input = @"<p>Hello</p><script type=""text/javascript"">const x = 29; console.log('Hello world');</script><p>World</p><script>alert('Hello world');</script><script src=""javascript.js""></script>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}