import Foundation
let pattern = #"\bA1\w+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\"glass_id\":\"A1324053BC04\"
\"glass_id\":\"A132500DAA04\"
\"glass_id\":\"A132602XBK04\"
\"glass_id\":\"A131M06UBG04\"
\"glass_id\":\"A132308RBC04\"
\"glass_id\":\"A132405PCJ04\"
\"glass_id\":\"A132405QBC04\"
\"glass_id\":\"A132500CAW04\"
\"glass_id\":\"A132S06DBR03\"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)