// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bA1\w+\b").unwrap();
let string = "\\\"glass_id\\\":\\\"A1324053BC04\\\"
\\\"glass_id\\\":\\\"A132500DAA04\\\"
\\\"glass_id\\\":\\\"A132602XBK04\\\"
\\\"glass_id\\\":\\\"A131M06UBG04\\\"
\\\"glass_id\\\":\\\"A132308RBC04\\\"
\\\"glass_id\\\":\\\"A132405PCJ04\\\"
\\\"glass_id\\\":\\\"A132405QBC04\\\"
\\\"glass_id\\\":\\\"A132500CAW04\\\"
\\\"glass_id\\\":\\\"A132S06DBR03\\\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}