using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bA1\w+\b";
string input = @"\""glass_id\"":\""A1324053BC04\""
\""glass_id\"":\""A132500DAA04\""
\""glass_id\"":\""A132602XBK04\""
\""glass_id\"":\""A131M06UBG04\""
\""glass_id\"":\""A132308RBC04\""
\""glass_id\"":\""A132405PCJ04\""
\""glass_id\"":\""A132405QBC04\""
\""glass_id\"":\""A132500CAW04\""
\""glass_id\"":\""A132S06DBR03\""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}