#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bA1\w+\b"
Local $sString = "\"glass_id\":\"A1324053BC04\"" & @CRLF & _
"\"glass_id\":\"A132500DAA04\"" & @CRLF & _
"\"glass_id\":\"A132602XBK04\"" & @CRLF & _
"\"glass_id\":\"A131M06UBG04\"" & @CRLF & _
"\"glass_id\":\"A132308RBC04\"" & @CRLF & _
"\"glass_id\":\"A132405PCJ04\"" & @CRLF & _
"\"glass_id\":\"A132405QBC04\"" & @CRLF & _
"\"glass_id\":\"A132500CAW04\"" & @CRLF & _
"\"glass_id\":\"A132S06DBR03\""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")