$re = '/\bA1\w+\b/m';
$str = '\\"glass_id\\":\\"A1324053BC04\\"
\\"glass_id\\":\\"A132500DAA04\\"
\\"glass_id\\":\\"A132602XBK04\\"
\\"glass_id\\":\\"A131M06UBG04\\"
\\"glass_id\\":\\"A132308RBC04\\"
\\"glass_id\\":\\"A132405PCJ04\\"
\\"glass_id\\":\\"A132405QBC04\\"
\\"glass_id\\":\\"A132500CAW04\\"
\\"glass_id\\":\\"A132S06DBR03\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);