package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bA1\w+\b`)
var str = `\"glass_id\":\"A1324053BC04\"
\"glass_id\":\"A132500DAA04\"
\"glass_id\":\"A132602XBK04\"
\"glass_id\":\"A131M06UBG04\"
\"glass_id\":\"A132308RBC04\"
\"glass_id\":\"A132405PCJ04\"
\"glass_id\":\"A132405QBC04\"
\"glass_id\":\"A132500CAW04\"
\"glass_id\":\"A132S06DBR03\"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}