const regex = /\bA1\w+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bA1\\w+\\b', 'gm')
const str = `\\"glass_id\\":\\"A1324053BC04\\"
\\"glass_id\\":\\"A132500DAA04\\"
\\"glass_id\\":\\"A132602XBK04\\"
\\"glass_id\\":\\"A131M06UBG04\\"
\\"glass_id\\":\\"A132308RBC04\\"
\\"glass_id\\":\\"A132405PCJ04\\"
\\"glass_id\\":\\"A132405QBC04\\"
\\"glass_id\\":\\"A132500CAW04\\"
\\"glass_id\\":\\"A132S06DBR03\\"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}