use strict;
my $str = '\\"glass_id\\":\\"A1324053BC04\\"
\\"glass_id\\":\\"A132500DAA04\\"
\\"glass_id\\":\\"A132602XBK04\\"
\\"glass_id\\":\\"A131M06UBG04\\"
\\"glass_id\\":\\"A132308RBC04\\"
\\"glass_id\\":\\"A132405PCJ04\\"
\\"glass_id\\":\\"A132405QBC04\\"
\\"glass_id\\":\\"A132500CAW04\\"
\\"glass_id\\":\\"A132S06DBR03\\"';
my $regex = qr/\bA1\w+\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}