import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bA1\\w+\\b";
final String string = "\\\"glass_id\\\":\\\"A1324053BC04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132500DAA04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132602XBK04\\\"\n"
+ "\\\"glass_id\\\":\\\"A131M06UBG04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132308RBC04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132405PCJ04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132405QBC04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132500CAW04\\\"\n"
+ "\\\"glass_id\\\":\\\"A132S06DBR03\\\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}