import Foundation
let pattern = #"(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""WIRELESS CALLER" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\"Company A\" \2\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)