package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)`)
var str = `"WIRELESS CALLER" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f`
var substitution = "\"Company A\" \2\3\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}