# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)/\"Company A\" \2\3\4/gm;t' <<< "\"WIRELESS CALLER\" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f"