import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Za-z0-9 \\\"]*)(\\<sip:)([\\+1]*8004001506)(.*\\>.*)";
final String string = "\"WIRELESS CALLER\" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f";
final String subst = "\\\"Company A\\\" \\2\\3\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}