// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)"#).unwrap();
let string = "\"WIRELESS CALLER\" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f";
let substitution = "\\\"Company A\\\" \\2\\3\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}