const regex = /(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[A-Za-z0-9 \\"]*)(\\<sip:)([\\+1]*8004001506)(.*\\>.*)', 'gm')
const str = `"WIRELESS CALLER" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f`;
const subst = `\"Company A\" \2\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);