$re = '/(^[A-Za-z0-9 \"]*)(\<sip:)([\+1]*8004001506)(.*\>.*)/m';
$str = '"WIRELESS CALLER" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f';
$subst = "\"Company A\" \2\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;