using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Za-z0-9 \""]*)(\<sip:)([\+1]*8004001506)(.*\>.*)";
string substitution = @"\""Company A\"" \2\3\4";
string input = @"""WIRELESS CALLER"" <sip:+18004001506@192.168.18.40;isup-oli=62>;tag=gK0461bc7f";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}